Unable to send out email on Wifi

Discussion in 'Android OS' started by scjjtt, Jun 16, 2012.

  1. scjjtt

    scjjtt A Former Palm User

    Messages:
    2,282
    Likes Received:
    3,924
    Trophy Points:
    288
    It seems around the time Sprint did an OTA latest update that I'm unable to send out emails while connected to WiFi. I have this problem on all networks - except the Sprint.

    This problem is with pop 3 accounts as well with Yahoo, Hotmail & Google accounts.

    Any suggestions?
     
  2. Hook

    Hook Professional Daydreamer

    Messages:
    19,112
    Likes Received:
    8,695
    Trophy Points:
    288
    I take it you don't have this problem with email on your computer and that you don't have other wifi problems on your phone? Have you done a battery pull or reboot of the phone? (Just trying to eliminate the obvious).
     
  3. scjjtt

    scjjtt A Former Palm User

    Messages:
    2,282
    Likes Received:
    3,924
    Trophy Points:
    288
    Hook: That's right - no problem with other computers or my HP Touchpad - & yes, almost every day I will pull the battery & put in a spare.

    Sprint's latest update causes the wifi to come on often all by itself. They did that so people will be using wifi more for data than Sprint's network. Now throughout the day I have to check if the wifi is on at places where I'm not using wifi to save battery.

    Before the update I would always use wifi just because it's faster. I really don't like the wifi turning on by itself.

    It's crazy - that's why I'm coming to my friends @ BH!

    Sent from my Samsung Epic 4g using Tapatalk.
     
  4. Hook

    Hook Professional Daydreamer

    Messages:
    19,112
    Likes Received:
    8,695
    Trophy Points:
    288
    Since the wifi is coming on automatically, is it possibly grabbing the wrong network if you are someplace with a lot of networks within range. I'm grabbing at straws because I haven't seen this problem.
     
  5. raspabalsa

    raspabalsa Brain stuck BogoMipping

    Messages:
    8,712
    Likes Received:
    5,419
    Trophy Points:
    288
    I haven't seen this problem either. About the only thing I can suggest is check WiFi advanced settings, see if there's anything under Proxy. It should be blank, unless the update set this to use a Sprint proxy.
     
  6. Drillbit

    Drillbit Mobile Deity

    Messages:
    4,024
    Likes Received:
    797
    Trophy Points:
    288
    Has nothing to do with the update. The problem is your settings. You are using POP and not IMAP on these three accounts. You're using the second email app, and if you use POP, you have to set the SMTP for the outgoing mail server.

    The SMTP address aka the outgoing server, is one that is associated with your ISP. In wireless mobile mode, that SMTP address would be a Sprint server.

    When you switch to wifi mode, you also switched your ISP from Sprint to your land line broadband provider, which for example, maybe Comcast, Verizon or AT&T. If for example if its Comcast, to get the outgoing mail sending, the SMTP address must now be Comcast's, since the ISP of the wifi is Comcast. But however, the SMTP address in your email app isn't going to change just because you switched from wireless to wifi, and the SMTP entry remains Sprint. Therefore it doesn't work.

    If you rewrote your SMTP address to the Comcast SMTP server, then you can send email. But when you switched from Wifi to wireless, the SMTP won't work again, unless you change back to Sprint's. Manually changing the SMTP address just because you change from wifi to wireless or vice versa, simply is inconvenient. If you go access wifi in public like in coffee shops and so on, once more the SMTP address needs to change to whatever the ISP''s being used on the Wifi. So it gets really complicated.

    This is why its not a good idea to use POP for email. It is better to use IMAP or Exchange Sync on those accounts. Or better yet, just use the dedicated mail apps. The GMail app is always bundled with Android; Yahoo Mail and Hotmail both have official apps in the Google Play Market. The specific email apps like for GMail, Yahoo Mail or Hotmail already have IMAP and push notifications preset. Go install them instead.
     
  7. jigwashere

    jigwashere Life is a circus!

    Messages:
    16,860
    Likes Received:
    10,452
    Trophy Points:
    288
    I'm a bit confused, scjjtt. I have Sprint's E4GT, too. My WiFi doesn't come on automatically -- I control it. My phone is up-to-date, too.
     
  8. scjjtt

    scjjtt A Former Palm User

    Messages:
    2,282
    Likes Received:
    3,924
    Trophy Points:
    288
    Jig, yeah it happened to all of our Samsung Epic 4 G phones in our family (3 of them - and my wife never modifies or does anything to her phone). I have a friend and the same thing has happened to him with his Epic 4g. We have the Epic 4g phones - not to be confused with the newer Epic 4g Touch like yours. We have the keyboard.
     
  9. scjjtt

    scjjtt A Former Palm User

    Messages:
    2,282
    Likes Received:
    3,924
    Trophy Points:
    288
    Drillbit, thanks for the reply - I'm going to have to sit down with your suggestions and try to work through them tomorrow - but the only thing I'm confused on is this: I never changed my settings - for a year everything worked up to about a month ago??????
     
  10. scjjtt

    scjjtt A Former Palm User

    Messages:
    2,282
    Likes Received:
    3,924
    Trophy Points:
    288
    Hook, no problem with grabbing wrong networks - I'll try Drillbit's suggestions tomorrow and respond after that...
     

Share This Page