Please Help me again ! m515 reflashing process failed ! ...and "blue-screen" !

Discussion in 'Palm' started by adru, Sep 23, 2003.

Thread Status:
Not open for further replies.
  1. adru

    adru Mobile Enthusiast

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    :confused:
    As I promise myself , I,ve tried this afternoon to reflash an m515 which was in reset loop , as says BAB2000, Steven etc. And I think, I'm not sure at all, that blank screen, when I pressed the down button, were some kind of debug reset mode ( in tandem with the only function of the power button, the "reset" one.

    So, after 2 days of "relaxing" for my m515, lefted in reset mode, to drain completely it's batteries, I've tried to reflash it as follows:
    - I've placed the palm in the cradle (conected to power source and to PC via USB cable) after I've done a reset in DEBUG mode, but I don't know if it were a succesfully reset because I've seen just a blank screen, without the flashing square in the upper-left corner, specified by installation/update program in it's instructins. Actually, I've repeated the "debug reset" procedure few times, trying to see that flashing square but without success, I've seen just the blank screen, lighted.
    - I've started the Palmm500_eng4_1_FlashNew.exe
    - First time it gaves me an error reffering it's not written for the specified device ( the right device was not detected )
    - Second time I've started it in advanced mode, where the upgrade process was started , and the progres indicator stopped after about 30 seconds (cca 2%) with an error.
    -Third and fourth time I've done the same thing (take the palm from cradle, debug reset, placed onto cradle again, restarted the update utility in advanced mode, followed on-screen instructions and, when the "next" button becames available, proceed again to reflash/"update" the palm m515 with an m505 version.
    The fourth time (and last, unfortunately) I've seen the bar progress indicator up to 56% but then, again, an error message.
    So I did again a debug reset and the result was a "blue-screen" with a white square around it. And that's all!
    After that, no "next" button available in upgrade utility, no other functionallity sindrom were present.Just the "blue-screen".With a white square around, next to margins. So I think the flash is gone.
    Totally.

    What can I do? ( to dig a hole in the gound and let it there to rest in peace? Or there is a final chance, the hardware repair one ? )

    Apropos, if someone could give me an(other) advice, I've worked as a debug-analyzer-repair man in a corporation manufacturer of electronics products under contract for many-very-well-known brands, I've replaced many times "flash" IC's and downloaded them with specific firmware. I have at my home all the tools I need (just for repair-replacing circuits etc, not download racks and software-hardware testers, of course , they're very expensive, prohibited actually!)

    Does anyone know how can I rewrite the flash IC in the protected area with the boot instructions to open the serial port for trying the update process again, assuming that I will succesfully replace the flash IC with an identical one?
    I must to mention that I never opened , neither now, a Palm. Does anyone know a place to find a service diagram for it ? A link?
    Or any other suggestions?
    Please?

    I'm going deepper and deepper !


    Thanks all of you, in advance !
    And many thanks and excuses for taking your patience to read this "poem" :)

    Adrian

    P.S. I've tried all of these, encouraged with the similar situation, finished succesfully by "dmiagro", posted here.
     
  2. BAB2000

    BAB2000 An "Olde Moderator" #2

    Messages:
    13,453
    Likes Received:
    175
    Trophy Points:
    258
    Adrian,
    The only error I observed was continually attempting to place in debug mode. When you have successfully placed unit in debug mode it will remain in that condition until a soft or hard reset is performed.

    I only can suggest, to let the battery drain again, then charge till point you have a display, then perform the debug reset and attempt the flash tool via advance mode again. If it appears to stop, I believe the next button may be enabled, or restarting the installer and attempting advance again and again may allow you to complete.

    Remember, once it is in debug it will remain in debug until a soft or hard reset interupts it.

    Good Luck, just remember, the world is waiting for you to be successful:D
     
Loading...
Similar Threads - Please Help again
  1. lelisa13p
    Replies:
    43
    Views:
    3,780
Thread Status:
Not open for further replies.

Share This Page