Palm Z22 problem

Discussion in 'PDAs and Handhelds' started by Dr Paul Fleming, Mar 3, 2017.

  1. Dr Paul Fleming

    Dr Paul Fleming Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi everyone,

    I recently purchased a Palm Z22 - I've used Palm PDAs before and they were pretty solid and reliable. I've charged this new one up and it switches on fine but then simply gets stuck in an iterative loop asking me to use the stylus to hit the on-screen target - it keeps repeating this and does not move on to any other screen. I've tried resetting it but this has not solved the problem - any suggestions?

    Thanks for your help with this.

    Paul
     
  2. raspabalsa

    raspabalsa Brain stuck BogoMipping

    Messages:
    8,140
    Likes Received:
    3,174
    Trophy Points:
    288
    Welcome to Brighthand, Dr Paul Fleming

    What you see is a malfunction of the Z22's touchscreen. When you tap on the target, the palm reads a different coordinate, not the expected one for target, and refuses to calibrate the screen until it "thinks" you've pressed the right coordinate. This can happen for a number of reasons. One is easy to check and fix: dust or lint particles can become trapped between the touchscreen and the screen bezel. If you look closely you'll see there's a narrow slit. If some particle lodges in there, it can press the screen and cause a false reading. To fix this, insert a small piece of paper in the slit and move it all along the slit, trying to scoop anything out. If this does not fix the problem, then you may need to replace the touchscreen. In this case, you can contact Chris Short at PalmDr. He can quote you a new touchscreen, or you can send him your device so he can diagnose and fix the problem.
     
    lelisa13p, scjjtt, jigwashere and 3 others like this.
Loading...

Share This Page