How to disable the WLAN blue LED!

Discussion in 'HP iPAQ 210 Enterprise Handheld' started by JanSamson, Mar 13, 2008.

Thread Status:
Not open for further replies.
  1. JanSamson

    JanSamson Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    3
    Does the blue LED shines to bright for you as well, especially in the dark.
    Make the following adjustment in the registry, and the BLUE led will be off permanently.

    Use a registry tool like Resco Registry.
    Open the following Place.
    HKEY_LOCAL_MACHINE\Drivers\Builtin\NLed
    Change the name of the entry DLL into for example xDLL, but do not delete it
    (In case you would like to revert back).

    Save the changes and do a softreset. If you make a WLAN connection ( or Bluetooth) the BLUE led stays off.

    Yours sincerely,

    Jan Samson
     
  2. buckyg

    buckyg Mobile Deity

    Messages:
    100
    Likes Received:
    0
    Trophy Points:
    21
    Cool, thanks! I'm tired of a little blue dot being burned into my eye everytime I use wifi at night!
     
  3. barsmonster

    barsmonster PalmAddict

    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    13
    Thanks alot, minus one small annoying thing :)
     
  4. buckyg

    buckyg Mobile Deity

    Messages:
    100
    Likes Received:
    0
    Trophy Points:
    21
    Works like a charm! Now I'll just have to remember to shut wireless off, so I don't get mysterious power drains...
     
  5. Adama D. Brown

    Adama D. Brown Brighthand Reviewer

    Messages:
    15,512
    Likes Received:
    403
    Trophy Points:
    258
    Welcome to Brighthand, JanSamson. That's good info. I wish there was a way to only disable the LED for Bluetooth activity, but if it bothers you this is the next best thing. Thanks.
     
  6. BenH

    BenH Mobile Consultant

    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    13
    Excellent, been waiting for this. Thanks matey.
     
  7. aikidoka

    aikidoka Mobile Enthusiast

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    i didn't know the exact sequence of what i did, but sometimes the led is turned of by itself while the wifi is still on, and i didn't do the registry hack.

    i am using Magic Button from TranCreative, and Wireless Today applet from Microsoft
     
  8. Adama D. Brown

    Adama D. Brown Brighthand Reviewer

    Messages:
    15,512
    Likes Received:
    403
    Trophy Points:
    258
    I've had that happen. I'm running Magic Button as well, but I more suspect that this is a firmware bug. The WiFi seems reluctant to turn on or off sometimes.
     
  9. showmethepda

    showmethepda Mobile Enthusiast

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    3
    I am currently running Opera Mini over wifi using the Esmertec Jbed java environment while I am waiting for Opera Mobile 9.5 to be released. I find that when I start the Opera Mini application the blue led shuts off and remains off until I exit the application, turn off my wifi connection, and reconnect to wifi. Then if turns on again.

    I have no idea why this occurs or if other's experience is the same, but thought it might provide some additional data on this issue.
     
  10. snivvy

    snivvy Mobile Enthusiast

    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    3
    I find a tiny piece of black electrical tape works just fine. Before I stick it over the LED I use a pin to put a teeny hole in it so I can still see the LED, not just so bright!
     
  11. deepblue

    deepblue Mobile Consultant

    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    8
    I used the Resco Registry to modify the value of the DLL. But it was gray out and I was not able to modify the name. Should I just modify the String "zylonite-nled.dll" to "zylonite-nled.xdll" ?

    Thanks
     
  12. deepblue

    deepblue Mobile Consultant

    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    8
    Problem solved. Thx.
     
  13. Konrad Pierce

    Konrad Pierce Village Idiot 2.0

    Messages:
    4,683
    Likes Received:
    0
    Trophy Points:
    213
    In cases like this (where you want to disable a Registry entry but also keep it "just in case"), you can always just rename the key into something else, so

    for example
    HKEY_LOCAL_MACHINE\Drivers\Builtin\NLed

    could become
    HKEY_LOCAL_MACHINE\Drivers\Builtin\disabled_by_me-NLed

    and you wouldn't even need to change the fields or values within.
     
  14. xtonda

    xtonda Mobile Deity

    Messages:
    115
    Likes Received:
    0
    Trophy Points:
    23
    I found elsewhere that setting "Flags" to is better solution because renaming "Dll" key causes some errors.
     
  15. mariusc80

    mariusc80 Mobile Enthusiast

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Setting
    [HKEY_LOCAL_MACHINE\Drivers\BuiltIn\NLED]
    "Flags"=dword:0

    makes the blue led go away for bluetooth as well as for wirelez.
     
  16. sliders7

    sliders7 GPS Specialist

    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    13
    Wonderful Tips guys!! Thanks

    Any idea how to turn off the Power Green/Orange LED??
     
  17. feg9812

    feg9812 Mobile Enthusiast

    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Wonderful!

    Following this, I found something as well.
    I noticed that the original value of Flages was 65544 which is equal to 10000000000001000 (binary). So I tried to change each "1" to "0" to see what'll happen. Here is it:


    10000000000000000 (binary)= 65536
    works same as "Flags"=dword:0", light disabled for both bluetooth and wireless


    00000000000001000 (binary)= 8
    DOES NOT work. Light on as usual

    Hope this helps :p
     
  18. 619girl

    619girl Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I have the 6800 and I was trying to disabled the blue LED and I disabled the vibrate mode. Does anyone have the orignal setting?

    The blue light is still on but the green light is off.
     
  19. jayanthd

    jayanthd Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Elegant solution since there is nothing in the registry to just "dim" the lights. I used a black permanent marker pen and dabbed a few splotches to dim the light.


    Jay
     
Similar Threads: disable WLAN
Forum Title Date
HP iPAQ 210 Enterprise Handheld Wlan button and problems Jul 19, 2008
HP iPAQ 210 Enterprise Handheld IPAQ Wireless is only WLAN - help? Mar 30, 2008

Thread Status:
Not open for further replies.

Share This Page