Help! mfc42.dll error Palm Desktop crashes

Discussion in 'V series' started by kickservebt, Nov 10, 2006.

Thread Status:
Not open for further replies.
  1. kickservebt

    kickservebt Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I'm creating a new thread because I didn't see a viable solution to any of the other threads having the same error. Maybe a more recent thread will help.

    Here is what happened.

    I got a new PC at work. I downloaded the newest version of Palm Desktop. I proceeded to HotSync my Vx. After Syncing, Palm Desktop crashes and closes. I try to re-open, it opens briefly, then the mfc42.dll error pops up. After clicking "OK" on the error, Palm Desktop closes.

    Here is what I have attempted.

    If I re-name my address book folder "old_address" for example, Palm Desktop opens fine, albeit with no address book info.

    I have tried uninstalling Palm Desktop, deleting the old user data and starting fresh. After re-installing, I change the Address Book to "Handheld overwrites Desktop". Re-Syncing....then the whole cycle begins again.

    Sounds like something is wrong with the address book data on my PDA. I don't see any obvious problems. I was thinking of re-syncing with "Desktop overwrites Handheld" as a last resort and re-entering my address book info. But it's not a guaranteed fix since I don't know what the problem is with the data in the current address book.

    HELP please!!! :)))
     
  2. Dick Tracy

    Dick Tracy Detective/Moderator

    Messages:
    17,695
    Likes Received:
    3
    Trophy Points:
    233
    Welcome to Brighthand kickservebt.

    A search on mfc42.dll found a number of threads. Try this one.
     
  3. Streaky

    Streaky I can't remember

    Messages:
    11,765
    Likes Received:
    0
    Trophy Points:
    233
    Welcome to Brighthand, kickservebt. How have you got on?
     
  4. BAB2000

    BAB2000 An "Olde Moderator" #2 Super Moderator

    Messages:
    13,398
    Likes Received:
    72
    Trophy Points:
    258
    Must ask, what version of Palm desktop did you download?

    If version 4.1.4E, the listed most recent, it is not compatible with your series V.

    If version 4.1.4, it includes the extended PIM functionality of the newer Palm handhelds, the function will not be applied to the series V. And if I remember if when prompted during th einstall to enter a USER name, and youu do select the name presently assigned to your handheld, conflicts will occur on th eolder devices, corruption of data can result as the Hotsync application is attemopting to synce old app formated data to new format, thus corruption as the wrong conduit set can be defaulted.

    It would be best, remove this installation, and also, delete the \Palm\{user name } folders. The reinstal, and when prompted for a anme , create a new one.

    Then hotsync your V, and the HS manager should detect as new, interogate the handheld, assign the coorect conduits (same as handheld apps) and then sync, creating the folders required and hopefully preventing the error that occured the first go.

    Or you can try this, Version 4.1 will also work with WinPX or Win2000, as it was first version compatible, and the USB drivers included are flly comapatible. Since V is serial device drivers not critical.

    As a caution, before sysncing, locate the \Palm|Update folder and rename to Oldupdates. If your unit is working with OS 3.5 or older, it is possible the updates will be automatically applied to the OS, this would be bad, as they are not 10% compatible with the OS on V and digitizer issues can surface.
     
  5. TarekAHF

    TarekAHF Mobile Deity

    Messages:
    459
    Likes Received:
    0
    Trophy Points:
    68
    Just today morning at work, I tried to open Palm Desktop for my Palm TX, and it crashed with similar error reported in this and other related posts.

    So, I read through this post:

    http://discussion.treocentral.com/showthread.php?t=109727

    and found it it really very useful, a new idea came to my mind.

    Actually, I am posting here in Brighthand, because I have an account, and do not want to create another account here and there !!

    I was able to find another solution, probably easier.

    So, I did the following steps:

    0. Did a complete backup for all important files/folders,

    1. Renamed the ToDo data file "todo.dat" to "todo-save.dat", and WOW, the Palm Desktop started without errors. It was a good guess, since I expected that this is the source of the problem due to "Nokia IntelliSync Enterprice Server" trial version which moved all my Lotus Notes ToDo from Notes DB to my Palm TX & Desktop due to a mistake (I was trying to avoid it since I have a huge ToDo in Notes), which happened about 2 months ago. So probably, the size of the ToDo grew very big (1331 records), which caused some unexpected behaviour/data corruption.

    2. Opened Palm Desktop, and opened the ToDo List which was empty.

    3. Deleted the empty "todo.dat" and renamed "todo-save.dat" to "todo.dat" and, on Palm Desktop, I executed menu option "File/Revert".

    4. After Revert, all my original ToDo records Appeared.

    5. Do a "Check and Repair" from menu Tools/Options/Tools. No errors.

    6. Verify all the data of all PIMs modules. In my case, I found that the Private records of my Memos were not showing and confirmed that all private records were deleted (after selecting Show Private Records) !!!. Did a quick chech on the other PIMs Data, compated the total number of records between the Palm TX and Desktop, and seemed to be OK. For callendare, I had to do random check which was looking fine, I hop !.

    7. Did a Dummy Change here and there, and Click Save then Close Palm Desktop, then open it back. The error/crash occurred again. So, back to step 1.

    8. After completing the steps until 7, I try to change User by clicking on the "User" Drop-Down Field on the top-right corener, and re-select my User Name again. This step seem to force to re-load all PIMs Data.

    9. Check Notepad Data and change Sort Order, and force re-load again, and change view of Notepad items. Bascically, try to play around with the Desktop options/functions/actions, hoping that some step will cure the error,

    10. I had to re-do all these steps 1-9 several times, as the error was still coming... but after some magic step, which I could not figure out which one exactly, the error was resolved completely !!!

    11. I recovered the Memo "memopad.dat" file from the backup I did before starting this procedure, and everything was back to normal.

    I hope some one else will find these steps useful. This will avoid uninstall/re-install mess, which may not solve a Data Corruption Problem.

    Tarek.
     
Similar Threads: Help mfc42dll
Forum Title Date
V series Data recovery? My Palm V erased itself :( and I need HELP Jun 25, 2008
V series Help, please...XP desktop w/ Palm OS 3.5, 3.1, or 4.1.4? Dec 20, 2007
V series Problems with Vx HotSync, Need help!! Feb 10, 2007
V series HELP!! My PalmV is dead:-(((( Sep 21, 2006
V series Help My Palm V Is Broken Jul 3, 2006

Thread Status:
Not open for further replies.

Share This Page