Gahhhhh IR???

Discussion in 'Palm' started by mutton-javelin, Jun 19, 2012.

  1. mutton-javelin

    mutton-javelin Mobile Deity

    Messages:
    158
    Likes Received:
    3
    Trophy Points:
    21
    Where is the menu to turn on IR receive?

    I seemed to have turn that off. Will this affect an external keyboard as well?:confused:

    My IR is on, but something is not working as it wont pick up from other Units.:mad:
     
    Last edited: Jun 19, 2012
  2. mutton-javelin

    mutton-javelin Mobile Deity

    Messages:
    158
    Likes Received:
    3
    Trophy Points:
    21
    I think it is working now. Not sure what is going on with the keyboard though.
     
  3. Hook

    Hook Hookette says 'Tis the season!

    Messages:
    20,169
    Likes Received:
    13,238
    Trophy Points:
    288
    The IR keyboard was always fussy. Fount it worked best to have arm locked all the way down on the right and put the TX in landscape with the IR port resting against the wand. also, check batteries.
     
  4. jigwashere

    jigwashere Mobile Deity

    Messages:
    18,090
    Likes Received:
    15,455
    Trophy Points:
    288
    Isn't there a setting in the keyboard driver to turn it on and off? I thought there was some kind of switch.
     
  5. hal

    hal itchy and cold feet hal

    Messages:
    5,293
    Likes Received:
    340
    Trophy Points:
    186
    There are two kinds of switches that are necessary in order to make the IR keyboard work.

    One, the IrDA itself. Applications Launcher: Prefs: Power: Beam Receive. If it's On, turn it Off, click Done, and open Power again, click Beam Receive On, and click Done. Very important, in this step you have to click Done inside the Power config screen in order to make the changes effective each time. This step is necessary cause the IrDA port sometimes behaves wonky. By effectively disabling it and reenabling it, the port itself won't be a part of the issue.

    Second, the keyboard driver itself, and make sure you got the driver installed in the first place, and there are two driver versions, only one will work with the TX, AFAIR it's v.1.13. Provided the right driver is already installed, you can proceed. Applications Launcher: Keyboard: On/Off. The swich is a big square on the upper portion of the driver's screen. If the keyboard isn't working, then be sure to turn it Off, and leave the driver. Again, open the driver app, put the switch On, and leave the driver.

    IME with devices bearing Palm OS v.5.4.9 and NVFS, sometimes all of the latter doesn't ensure the keyboard/IrDA assembly works fine, sometimes you have to reset the device, but before that, get to the keyboard driver app and turn it Off, and only then do a soft reset. Besides, also IME with these devices, there is a significant lag in order to open the keyboard driver app. I believe that is due to NVFS.

    IME with the Palm IrDA keyboards, the batteries can work fine even at levels as low as 25%. The effective gap from the keyboard wand's transmitter to the device's IrDA port is more important, in both distance and angle, than the batteries' energy level. I'd agree with Hook in that the best practice for the TX would be to rest the device in landscape mode. The TX is way taller than my Treo 680 and the wand barely clears above the latter in portrait mode (the only way to put the 680 on the keyboard, anyway). I believe that the TX's IrDA port is much more powerful than the Treo 680's, so you can use that in your benefit.
     
  6. raspabalsa

    raspabalsa Brain stuck BogoMipping

    Messages:
    9,758
    Likes Received:
    10,270
    Trophy Points:
    288
    To be sure the keyboard is ok, test it with a cellphone camera (or a real digital camera), turn the keyboard on, point the camera's lens at the keyboard's IR port, then press any key on the keyboard. On the camera's viewfinder you should see a blue-reddish light, which is the IR transceiver (digital cameras are sensitive to IR and will translate it to visible light). You can test the Palm's IR port the same way: initiate beam, point the camera, you will see the pulsating light that indicates the TX is looking for another IR device.

    This has happened to me on several occasions. Newer palm models (particularly the TX and T5) would sometimes refuse to connect via IR with older Palm models. Beaming would always work ok between newer models, though.

    In the TX's Prefs app you can turn the IR on and off. IIRC turning this option off prevented the Palm from connecting to the IR keyboard. Also, as jig says, there is a switch to turn the keyboard connection on and off from the kb driver app.
     

Share This Page