Connect HTC Desire to home WiFi

Discussion in 'Android OS' started by abenn, May 1, 2010.

  1. abenn

    abenn Mobile Deity

    Messages:
    217
    Likes Received:
    8
    Trophy Points:
    93
    I've just got my HTC Desire, and at the moment I'm overwhelmed by all the features available on it. I've downloaded the 211-page manual, so things may soon become clearer.

    But the one thing I've tried so far -- connecting to the internet via my home modem/router's WiFi -- I've been unable to achieve despite reading the Wi-Fi section in the manual:

    My router/modem is Netgear DG834G, and its wireless access point is enabled and broadcasting its name. Security is set to WPA2-PSK.

    When I go to the WiFi settings on my Desire, it lists my router (and a couple of others down the street), and reports an excellent signal. But when I tap on the router name, then on the Connect button, nothing seems to happen, and it still displays "Disconnected" under the Wi-Fi label.

    What might I be doing wrong, please? Do I need to set up an access list in my router software? Is it the security setting on my router? Or am I simply taking the wrong approach?
     
  2. Hook

    Hook Hookette's edgy lately

    Messages:
    16,952
    Likes Received:
    2,391
    Trophy Points:
    288
    I'm not sure. This shouldn't be difficult at all. I've got a Netgear WGR614 router with WPA2-PSK security and my Nexus One just connected, all I had to do was type in the passkey once.

    Find another wifi access point and confirm that the Desire connects. If not, maybe the Desire is defective. Otherwise, I'd look in the router settings to see if there is some problem.

    As far as Android goes, it should be pretty routine.
     
  3. JRakes

    JRakes NOT your Average Joe

    Messages:
    16,940
    Likes Received:
    530
    Trophy Points:
    288
    I was waiting for Hook to jump in, since he's got a more similar device. But, yes - It should be a simple, one-time "let me connect" action and it will connect anytime you're within range of the signal thereafter. That's how my WM TP2 works, connecting with my D-Link router in about 10 seconds the first time, and automagically thereafter.

    I agree with Hook: Check the router config / settings to make sure it isn't blocking or locking out other devices. Otherwise, make sure you've selected the correct connection on the Desire. It really should be quite easy.

    Good luck! :)
     
  4. abenn

    abenn Mobile Deity

    Messages:
    217
    Likes Received:
    8
    Trophy Points:
    93
    You have me worried now. Things went just as you've described -- I had to type in my router password the first time I tried to connect, and subsequently my Desire hasn't asked me for a password, it's just allowed me to connect. But I can't access any web site, and when I go back to the Settings/Wireless & networks page on my Desire, it says "Disconnected" under the Wi-Fi option, even though there's a green tick against it.

    I've checked my router settings once again. I'm new to this too, but the only possibility I can see is that under the heading "Firewall Rules" there are no rules listed which, according to the help file, means that all outbound traffic is permitted and all inbound traffic is blocked. Is this what's stopping my Desire from communicating via Wi-Fi? If so, I've got a bit of research to do because I don't know what LAN Server IP Address (required if I want to create a new rule) I need to use.
     
  5. Hook

    Hook Hookette's edgy lately

    Messages:
    16,952
    Likes Received:
    2,391
    Trophy Points:
    288
    Don't mess with the rules. If you have not changed many of the defaults in your router, other than creating name and setting security level, don't mess with the router. My rule of thumb is, if you don't understand how something works (me and routers), don't go changing settings when you don't know what the problem is.

    Have you rebooted the router recently? Unplug it, wait 30 seconds and then plug it back in.

    If that doesn't work, go to a free wifi hotspot somewhere like a coffee shop or your local library and see if you connect. Make sure you are getting a wifi connection and not 3G.

    If you connect fine, go back home and select your network. I'm not sure which version of Android you have --I have 2.1-- but mine will offer to forget the network. Do so. Then find it again. This should require you to retype the pass-phrase. Maybe you somehow got it wrong or the data became corrupted. See what happens.

    If none of this works, I would try HTC tech support (because I think they will be more helpful than Netgear, but you can try both).

    Report your progress here.
     
  6. abenn

    abenn Mobile Deity

    Messages:
    217
    Likes Received:
    8
    Trophy Points:
    93
    Thanks, Hook. I've re-booted my router several times. I'll try "forget" on the phone, and then re-acquire the network to see if that works.

    I only visit town once a week, so that's why I'm trying to learn how the Wi-Fi part of my phone works using my home system. I'll try one of the coffee shops with free Wi-Fi when I visit next week. One of the first things I did when I got the phone was switch off the 3G internet access, because I don't want to pay their high charges ;-))
     
  7. Drillbit

    Drillbit Mobile Deity

    Messages:
    3,815
    Likes Received:
    510
    Trophy Points:
    288
    Its possible that the router/modem maybe set to only one device. Some ISPs do that if the router/modem came from them. I had this experience before. Might need someone familiar with router setup to check on this one.
     
  8. abenn

    abenn Mobile Deity

    Messages:
    217
    Likes Received:
    8
    Trophy Points:
    93
    Thanks, Drillbit. The modem came from a large electrical retailer, so should be "unlocked". Although I'm new to routers, going through all the menus on the screen, I can't see anything that would suggest it's set to a single device.

    Hook, I've told my phone to forget my Wi-Fi, and then re-acquired it and input the password. For a moment it indicated Wi-Fi was connected, but then reverted to "disconnected". All my router settings are factory, except for my own password.

    Seems like I'm doing everything right, so we'll have to wait until I can get to a Wi-Fi hotspot at the end of the week to see if there's a fundamental problem with the phone.
     
  9. RickAgresta

    RickAgresta Above: Peanut, leader of the Peanutty Forces

    Messages:
    15,469
    Likes Received:
    2,629
    Trophy Points:
    288
    you could try tempprarily disabling security on your router, telling the Desire to forget as above, and trying to connect; if that works then re-enable, telling the Desire to forget as above, and try again.

    I'm assuming that there is no issue of which wifi band being used; for example, some 'mature' devices only support 802.11b, and in turn have major problems with *some* routers (usually if the router is in a mixed mode of some sort)
     
  10. wesselrossing

    wesselrossing Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Short story:
    It is probably your wireless router, my phone produced exactly the same behaviour as you described and I found out it was my wireless router to blame. For me a simple unplugging and replugging the router worked out.

    Long story:
    I have been experiencing similar problems to yours, abenn. I bought my HTC Desire yesterday, and was able to connect to my wifi network without problems. I left the wifi connection on for the night and when I woke up this morning the connection was still up but when I accessed the internet the G icon turned on and the data was returned over the mobile internet connection.

    Then I proceeded and turned wifi off, on again, off again etc. to no avail. I made the phone forget about my home network and re-entered the password, still nothing. I did the same when I unchecked the mobile internet connection but nothing seemed to happen (exactly as how you described it).

    I surfed the internet (using the mobile internet connection) on the Desire and came across your thread, when I wanted to reply I decided to do so from a computer because I am not yet used to the on screen keyboard (I used to have a HTC G1). But the computer could not connect to the home network either, so I unplugged the wireless router, plugged it in again, waited 10 seconds or so and the computer could connect to the network again. Than I grabbed my Desire and it was already happily showing the wireless symbol. Ofcourse I tested the network connection and it achieved speeds not possible over 3G so it has to be working.
     
  11. abenn

    abenn Mobile Deity

    Messages:
    217
    Likes Received:
    8
    Trophy Points:
    93
    OK, I temporarily deleted the security options from my router, and my phone immediately recognised it as an open connection, and connected me and showed the Wi-Fi symbol. But by the time I had typed in a www. address the phone had disconnected itself, the symbol had gone, and it was showing a green tick against the Wi-Fi menu option, but stating "Disconnected". That's the same as happens when I have normal security enabled.

    My router is new. It is using "WMM (Wireless Multimedia) ... a subset of the 802.11e standard".

    wesselrossing, I can't rule out a router problem, but I've re-booted it several times, and switched its wireless function on and off several times (my PC is connected to it by cable), without any change to the problem.
     
  12. JRakes

    JRakes NOT your Average Joe

    Messages:
    16,940
    Likes Received:
    530
    Trophy Points:
    288
    Welcome to Brighthand, wesselrossing! :D

    Abenn, as Rick suggested above, have you confirmed that the comm protocol of your router matches that of the Desire, i.e. 802.11b, -g, -n, etc? I'm definitely no expert, but I'm not sure what the -e or WMM standard is. Perhaps the desire is looking for a basic -b, -g, or -n connection, attempts to connect, then can't handle the -e.

    My router is a few years old and only does -b / -g. Any device can easily connect via either protocol. Perhaps your router also allows devices to connect via whatever protocol they use - Just "thinking out loud here."

    Hopefully you can get it sorted soon!
     
  13. RickAgresta

    RickAgresta Above: Peanut, leader of the Peanutty Forces

    Messages:
    15,469
    Likes Received:
    2,629
    Trophy Points:
    288
    Abenn, if this was me, I'd set the wireless channel to a "standard" protocol, such as 802.11-g or -n. while I freely admit to *not* being on top of all tech news, this is the 1st time I've heard of 802.11-e, let alone WMM. EDIT: posting from my TX‚ so didn't see that JRakes had suggested/implied much the same as I just suggested

    @wesselrossing: Welcome to Brighthand!
     
  14. wesselrossing

    wesselrossing Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks guys for the warm welcome!

    The HTC Desire specification says the device works with IEEE 802.11 b/g networks. I know IEEE 802.11 n is backwards compatible with those standards, so I agree with the previous posters that it is worth a try to set the wireless router to the IEEE 802.11 n standard.
     
  15. JRakes

    JRakes NOT your Average Joe

    Messages:
    16,940
    Likes Received:
    530
    Trophy Points:
    288
    Yeah, I did a bit of poking about and found that the -e standard (WMM) is targeted primarily at VoIP and streaming media, and one reference that mentioned the possibility that the protocol might actually block other data transmission. The purpose, apparently, is to give top priority to the media aspect and bumps other stuff down in priority. At least that was my layman's interpretation. :eek:

    So, yeah - I'd guess a more typical b/g/n setting would be my next course of action.
     
  16. abenn

    abenn Mobile Deity

    Messages:
    217
    Likes Received:
    8
    Trophy Points:
    93
    Thanks for all the research you've done. Just to clarify, my reference to the 802.11e protocol came from the help file associated with security options. It was explaining what security standard WPA-PSK2 is and, strangely, when I go back to that file (which is read from the internet), the reference to 802.11e is not there.

    According to the ad from which I ordered the router, it uses IEEE 802.11b, IEEE 802.11g, IEEE 802.1x, Wi-Fi CERTIFIED, but I can't find this info anywhere in the documentation which came with it. And I can't find any way to change the setting.

    I'm a bit out of my depth here, so let's wait until I've had a chance to take the phone to a Wi-Fi hotspot next week, to see if it works there.
     
  17. JRakes

    JRakes NOT your Average Joe

    Messages:
    16,940
    Likes Received:
    530
    Trophy Points:
    288
    There's probably some setting buried deep in some config menu somewhere. I think you're wise to leave it alone if you're unsure of what you're doing. The WiFi hotspot test seems (to me) to be a wise next step. At least then you might further isolate the actual source of the issue.

    Best of luck!
     
  18. Varjak

    Varjak Mobile Deity

    Messages:
    6,428
    Likes Received:
    34
    Trophy Points:
    0
    Just to add, it's been pretty well-documented here on BH that some mobile devices don't play well with routers 'broadcasting' mixed-protocol WiFi (like b/g or b/g/n). Specifying a single protocol for the router to use seems to work best, even if, as Wessel says, it's backwards compatible.

    And I don't claim to be a tech expert; but I've never heard of 802.11e either. I did find this link buried in the Wikipedia entry for WiFi:

    IEEE 802.11e-2005 - Wikipedia, the free encyclopedia

    At the bottom, there's a further link to the WMM protocol.
     
  19. abenn

    abenn Mobile Deity

    Messages:
    217
    Likes Received:
    8
    Trophy Points:
    93
    Thanks for your input, Varjak. I've just set my router to "g only" instead of "b and g", but my phone still can't connect. It still shows "connecting..." when I try to connect, but then shows "Disconnected" after about five seconds.

    Forget about my earlier reference to 802.11e -- that was somewhere in the Netgear help file, but I've now confirmed that my unit uses b and g only.
     
  20. abenn

    abenn Mobile Deity

    Messages:
    217
    Likes Received:
    8
    Trophy Points:
    93
    Faaaantastic :))

    I found an excuse to go into town today, and my phone linked up with the free Wi-Fi in a coffee shop without any problem.

    So, now I can concentrate on learning my way around the phone. Finding out why it won't connect to my home wireless is not so important now that I know the phone is working.

    Thanks again for all your input.
     
Similar Threads: Connect Desire
Forum Title Date
Android OS Connecting my Samsung Galaxy S3 using bluetooth. Feb 14, 2014
Android OS No datas connection with HTC One S unlocked T-Mobile Jul 22, 2012
Android OS Can camera connect to Android device? Jun 2, 2012
Android OS Connect Android phone to LCD Projector using WiFi Aug 17, 2011
Android OS Anyone using Quick Office Connect? Jun 29, 2010

Share This Page