ActiveStink

Discussion in 'iPAQ hx4700 series' started by stormlocke, Nov 21, 2004.

Thread Status:
Not open for further replies.
  1. stormlocke

    stormlocke Mobile Evangelist

    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    11
    Hi, I'm a total newbie when it comes to PPC. I've installed Activesync according to instructions and even got it working fine to sync outlook information (nothing big - only address, calendar and tasks).

    Next day, when I plug in the hx4700, the Activesync gave me an error: Synchronization failed. There was no other error message, and I don't even see the Address/Calendar/Tasks listed below. However, it says "Connected".

    I troubleshooted by doing the following after reading this (http://www.cewindows.net/faqs/activesync/syncerrors.htm):
    1. Soft reset the PPC device - same error
    2. Deleting the partnership and recreating another - same error
    3. Disabling all the options and try to troubleshoot by enabling one by one? didn?t help since it still failed
    4. Hard reset the PPC device *ouch* - same error
    5. Check whether it was due to Firewall or WinXP SP2 and disabled firewall. - same error
    6. Check whether my repl.dat is still there - Yes.
    7. Uninstalling Activestink and reinstalling, then re-setup the partnership

    Finally it worked! But few hours later, I plugged in my PPC and to my horror, activesync reported the "Synchronization failed" again!!

    I'm really at my wits end and ready to pull out all my hair and ship to Bill. I'm not a very technical person, so I hope someone here can help. I'm running activesync 3.7.1.

    Thanks!
     
  2. Compusmurf

    Compusmurf Mobile Deity

    Messages:
    752
    Likes Received:
    0
    Trophy Points:
    66
    Try running scanpst on your Outlook data file. You may have corruption in it.

    Also, if you are syncing via cradle, make sure the usb is plugged directly INTO the PC and not in a usb hub...
     
  3. wolwol

    wolwol Mobile Deity

    Messages:
    707
    Likes Received:
    0
    Trophy Points:
    66
    my cradle is hooked to a usb hub *powered one that is*
    no problem, other than the occasional activesync error...which can be solved easily by unseating the hx and seating it again
     
  4. Compusmurf

    Compusmurf Mobile Deity

    Messages:
    752
    Likes Received:
    0
    Trophy Points:
    66
    Yeah, but YOU aren't the one having issues....

    Not all hubs and motherboards are created equal.

    :)
     
  5. Hx4700

    Hx4700 Mobile Deity

    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    21
    Compusmurf is right on this -
    I had trouble last year and solved it by hooking cradle directly into pc (no hub) and after it worked the first time I could then use the hub (non-powered at that). Go figure :rolleyes:
    Ron...
     
  6. stormlocke

    stormlocke Mobile Evangelist

    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    11
    Sad to say, I'm already plugged in to a USB2 port on my PC directly, and not to a USB hub (although I've tried that too). Any other suggestions?

    I checked the wcescomm.log and it says this:

    11/22/2004 06:33:13.406 - Windows CE Services (3.7.4034) Communication Logging.
    11/22/2004 06:33:13.406 - Logging file auto-purge after a successful device connection.
    11/22/2004 06:33:13.406 - Connection: Process connection from IP address 127.0.0.1:1063.
    11/22/2004 06:33:14.546 - CesProxy: Accept on port 990, IsWinsock 1, hResult 0
    11/22/2004 06:33:14.546 - TCP: ....S., 192.168.55.100(1025) => 192.168.55.101(990) Seq=146125-146125 Ack=0 Win=8192 Len=44
    11/22/2004 06:33:14.562 - TCP: .A..S., 192.168.55.101(990) => 192.168.55.100(1025) Seq=297995512-297995512 Ack=146126 Win=65535 Len=44
    11/22/2004 06:33:15.640 - CesProxy: recv failed on Win socket 990, err = 10054
    11/22/2004 06:33:15.640 - CesProxy: Close Win socket 990
    11/22/2004 06:33:15.656 - CesProxy: Close PPP socket 990
    11/22/2004 06:33:15.656 - TCP: ...R.., 192.168.55.100(1025) => 192.168.55.101(990) Seq=146316-146316 Ack=297995553 Win=0 Len=40
    11/22/2004 06:33:15.656 - CesProxy: recv failed on PPP socket 990, err = 10053
    11/22/2004 06:33:15.734 - CesProxy: Accept on port 990, IsWinsock 1, hResult 0
    11/22/2004 06:33:15.750 - TCP: ....S., 192.168.55.100(1026) => 192.168.55.101(990) Seq=147312-147312 Ack=0 Win=8192 Len=44
    11/22/2004 06:33:15.750 - TCP: .A..S., 192.168.55.101(990) => 192.168.55.100(1026) Seq=298336398-298336398 Ack=147313 Win=65535 Len=44
    11/22/2004 06:33:19.812 - TCP: ....S., 192.168.55.101(1040) => 192.168.55.100(999) Seq=299390916-299390916 Ack=0 Win=65535 Len=48
    11/22/2004 06:33:19.812 - Proxy: Connection Attempt on port 999, dest ip 0x6437a8c0
    11/22/2004 06:33:19.812 - TCP: .A..S., 192.168.55.100(999) => 192.168.55.101(1040) Seq=151390-151390 Ack=299390917 Win=8760 Len=44
    11/22/2004 06:33:19.937 - CesProxy: Accept on port 999, IsWinsock 0, hResult 0
    11/22/2004 06:33:24.500 - CesProxy: recv failed on Win socket 999, err = 10054
    11/22/2004 06:33:24.515 - CesProxy: Close PPP socket 999
    11/22/2004 06:33:24.515 - TCP: ...R.., 192.168.55.100(999) => 192.168.55.101(1040) Seq=151397-151397 Ack=297370017 Win=0 Len=40
    11/22/2004 06:33:24.515 - CesProxy: recv failed on PPP socket 999, err = 10053
    11/22/2004 06:33:24.515 - CesProxy: Close Win socket 999
    11/22/2004 06:33:26.500 - TCP: ....S., 192.168.55.101(1042) => 192.168.55.100(5678) Seq=301099046-301099046 Ack=0 Win=65535 Len=48
    11/22/2004 06:33:26.515 - Proxy: Connection Attempt on port 5678, dest ip 0x6437a8c0
    11/22/2004 06:33:26.515 - TCP: .A..S., 192.168.55.100(5678) => 192.168.55.101(1042) Seq=158093-158093 Ack=301099047 Win=8760 Len=44
    11/22/2004 06:33:26.515 - TCP: ....S., 192.168.55.101(1043) => 192.168.55.100(5678) Seq=301144022-301144022 Ack=0 Win=65535 Len=48
    11/22/2004 06:33:26.515 - TCP: .A..S., 192.168.55.100(5678) => 192.168.55.101(1043) Seq=158093-158093 Ack=301144023 Win=8760 Len=44
    11/22/2004 06:33:27.593 - CesProxy: Accept on port 5678, IsWinsock 0, hResult 0
    11/22/2004 06:33:28.671 - Proxy connect to IPAddr 127.0.0.1 on socket 5678, results 10061
    11/22/2004 06:33:28.671 - CesProxy: Close Win socket 5678
    11/22/2004 06:33:28.671 - CesProxy: Close PPP socket 5678
    11/22/2004 06:33:28.671 - TCP: ...R.., 192.168.55.100(5678) => 192.168.55.101(1042) Seq=158094-158094 Ack=297370021 Win=0 Len=40
    11/22/2004 06:33:28.671 - Proxy: Error creating a new session 8007274d (okay on disconnect)
    11/22/2004 06:33:28.687 - CesProxy: Accept on port 5678, IsWinsock 0, hResult 0
    11/22/2004 06:33:28.687 - TCP: ...R.., 192.168.55.101(1043) => 192.168.55.100(5678) Seq=301144023-301144023 Ack=143981 Win=0 Len=40
    11/22/2004 06:33:29.656 - Proxy connect to IPAddr 127.0.0.1 on socket 5678, results 10061
    11/22/2004 06:33:29.656 - CesProxy: Close Win socket 5678
    11/22/2004 06:33:29.656 - CesProxy: Close PPP socket 5678
    11/22/2004 06:33:29.656 - Proxy: Error creating a new session 8007274d (okay on disconnect)
    11/22/2004 06:35:11.171 - UsbComm: Change DTR to 0.
    11/22/2004 06:35:11.171 - Proxy: Change connection state 0.
    11/22/2004 06:35:11.171 - UsbComm: Closed device.
    11/22/2004 06:35:11.187 - USB: Event 32772, name \\?\USB#Vid_03f0&Pid_1016#5&3ad090d&0&1#{25dbce51-6c8f-4a72-8a6d-b54c2b4fc835}
    11/22/2004 06:35:11.187 - CesProxy: Close PPP socket 5678
    11/22/2004 06:35:11.187 - USB: Device Remove Complete notification
    11/22/2004 06:35:11.187 - CesProxy: Accept on port 5678, IsWinsock 0, hResult 80072714
    11/22/2004 06:35:11.203 - CesProxy: Close PPP socket 999
    11/22/2004 06:35:11.203 - CesProxy: Accept on port 999, IsWinsock 0, hResult 80072714
    11/22/2004 06:35:11.203 - CesProxy: Close PPP socket 7438
    11/22/2004 06:35:11.203 - CesProxy: Accept on port 7438, IsWinsock 0, hResult 80072714
    11/22/2004 06:35:11.218 - CesProxy: Close PPP socket 5679
    11/22/2004 06:35:11.218 - CesProxy: Accept on port 5679, IsWinsock 0, hResult 80072714
    11/22/2004 06:35:11.218 - CesProxy: Close Win socket 1026
    11/22/2004 06:35:11.265 - CesProxy: Accept on port 1026, IsWinsock 1, hResult 80072714
    11/22/2004 06:35:11.312 - CesProxy: Close Win socket 990
    11/22/2004 06:35:11.343 - CesProxy: Accept on port 990, IsWinsock 1, hResult 80072714
    11/22/2004 06:35:11.343 - CesProxy: Close Win socket 990
    11/22/2004 06:35:11.343 - CesProxy: recv failed on Win socket 990, err = 10053
    11/22/2004 06:35:11.359 - CesProxy: Close PPP socket 990
    11/22/2004 06:35:11.359 - CesProxy: recv failed on PPP socket 990, err = 10053
    11/22/2004 06:35:11.375 - CesProxy: Close PPP socket 7438
    11/22/2004 06:35:11.375 - CesProxy: recv failed on PPP socket 7438, err = 10053
    11/22/2004 06:35:11.375 - CesProxy: Close Win socket 7438
    11/22/2004 06:35:11.390 - CesProxy: recv failed on Win socket 7438, err = 10053
    11/22/2004 06:35:11.406 - CesProxy: Close PPP socket 5679
    11/22/2004 06:35:11.406 - CesProxy: recv failed on PPP socket 5679, err = 10053
    11/22/2004 06:35:11.406 - CesProxy: Close Win socket 5679
    11/22/2004 06:35:11.421 - CesProxy: recv failed on Win socket 5679, err = 10053
    11/22/2004 06:35:14.484 - Shut down desktop passthru TCP2UDP component
    11/22/2004 06:35:14.500 - Connection: Prep for a new socket connection.

    The WCESMgr.log says this:

    **** ActiveSync (3.7.4034 RETAIL) started, Cmd line: '/onconnect'
    2004-11-22 06:33:15 00000934 - Checking existing partnership on device 0xA1B1D74.
    2004-11-22 06:33:17 00000948 - DTPT: Setting DTPT network to {ADB0B001-10B5-3F39-27C6-9742E785FCD4}
    2004-11-22 06:33:17 00000948 - DTPT: Send DTPT Network={ADB0B001-10B5-3F39-27C6-9742E785FCD4}. Result=0x00000000
    2004-11-22 06:33:17 00000948 - Server sync version: 1.1
    2004-11-22 06:33:17 00000948 - Found PIM at 'C:\PROGRA~1\MICROS~2\Office10\OUTLOOK.EXE'
    2004-11-22 06:33:17 00000948 - Found PIM at 'C:\PROGRA~1\MICROS~2\Office10\OUTLOOK.EXE'
    2004-11-22 06:33:18 00000934 - Connected to device 0xA1B1D74 (PocketPC, Pocket_PC) [partner 0]
    2004-11-22 06:33:18 00000934 - **** Starting synchronization engine
    2004-11-22 06:33:23 000000A8 - WARNING: Unknown command header 19427. Ignoring next 0 bytes. [76, 4]
    2004-11-22 06:33:23 000000A8 - [Ctrl Recv] [0x294]: Communication socket error 0, returned 0
    2004-11-22 06:33:23 00000954 - ERROR: SE_QUIT_02 returned 0x80145102, file: d:\medusa3.71qfe\private\apps\conn\repl\wcesmgr\.\cecmd.cpp, line 158
    2004-11-22 06:33:23 00000954 - ERROR returned in function CCmdBase::Send. hr: 0x80145102
    2004-11-22 06:33:23 00000954 - ERROR: cmdGetSSP.Send( m_comm.CtrlChannel() ) returned 0x80145102, file: d:\medusa3.71qfe\private\apps\conn\repl\wcesmgr\.\cesync.cpp, line 4322
    2004-11-22 06:33:23 00000954 - ERROR returned in function CCeSync::ConnectThrd. hr: 0x80145102
    2004-11-22 06:33:23 00000934 - ERROR returned in function CCeSync::QueryDevice. hr: 0x80140009
    2004-11-22 06:33:23 00000934 - ERROR: Initialization of SSP 'Microsoft Outlook' failed. Error: 0x80140009.
    2004-11-22 06:33:23 00000934 - ERROR: Unable to start SSP 'Microsoft Outlook'. Error code: 0x80140009
    2004-11-22 06:33:23 00000934 - ERROR: SE_QUIT_09 returned 0x80145109, file: d:\medusa3.71qfe\private\apps\conn\repl\wcesmgr\.\cesync.cpp, line 4879

    Can someone kindly explain this to me? Thanks a million!
     
  7. Hx4700

    Hx4700 Mobile Deity

    Messages:
    144
    Likes Received:
    0
    Trophy Points:
    21
    OK - this is the absolute strongest action you can take to subdue an ActiveSync problem that will not succumb to any other solutions:
    On the night of the next full moon, at midnight, you must bury a dead squirrel with the head facing down and pointed exactly due north. And at least two feet deep so that it won?t be disturbed by any other animals digging it up for at least two weeks.
    This has proven to be 100% successful in solving this type of ActiveSync problem by those who have done this procedure correctly. :eek: :eek: :eek:

    But seriously bro ? there have been times with ActiveStink that I have change ports, used the sync cable instead of the cradle, uninstalled/reinstalled Outlook and then pow! ? it would start working ? and I still don?t know what was the magic bullet.
    But good luck anyhow?and don?t give up changing things around?
    Ron?
    PS - I did think of one other thing I haven't seen mentioned. The version of AS - 3.7 was much better than 3.5. But 3.7.1 was worse. Again, go figure.
     
  8. stormlocke

    stormlocke Mobile Evangelist

    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    11
    Hmmm... dead squirrels. Let's see.... ;>

    Thanks bro. I will try the switching ports etc etc (but not the squirrel). Would it be better to switch to v3.7? Anyone else have that experience?

    Appreciate if anyone else could 'decode' the cryptic errors above and give me some answers. Thanks!
     
  9. imported_gavinfabl

    imported_gavinfabl Mobile Deity

    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    21
    Activesync 3.71 works fine. Don't use an earlier version.

    Just remember moving from palm to ppc takes a little adjustment, as I found out.

    I also realised its not necessary to hard reset and the like. There's normally no need.

    As long as you once or twice a day use the ipaq backup and in the options select PIM mirroring, you will not lose any settings.

    There is a difference fitting a USB directly into your PC as opposed to a USB hub.

    However, I see you have tried most of the obvious things - I wonder if you have a faulty cable.

    Have you contacted HP suport yet?

    Are your running SP2 or SP1?
     
  10. stormlocke

    stormlocke Mobile Evangelist

    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    11
    Yep, I've tried connecting direct USB2 port to PC, as well as by USB2 Hub. Both will work for a while, and then fail on me after a while. It's really frustrating.

    Thanks for your reassurances. I do understand it's not easy to switch systems and try to be more patient However, this Synchronization error is really crazy. This is like the basic function of a PDA, and I'm really horrified that it has so much problem (especially after I looked at the article on troubleshooting activesync). Palm has never given me this kind of crap before (even on my worst days). I'm not saying the HX4700 is bad... I really love the device and I think WM2003se has many great features. But this synchronization problem is really too much for me.

    I have not tried USB cable sync but that's a good idea... I will try it out. I've already logged a ticket to HP, and waiting for a reply. I'm running WinXP SP2.

    Any other suggestions? I tried to search for error codes in the log file I pasted up there, but can't find anything (or my searching skill sucks). :(
     
Thread Status:
Not open for further replies.

Share This Page